#163 open
Sean McGilvray

Search does not return any results

Reported by Sean McGilvray | January 14th, 2010 @ 10:39 AM | in 0.9.11 "Euwe"

When I do any type of search, in admin, users, campaigns, leads, or contacts, it does not return any results. The graphic that shows it is searching never goes away. Any ideas on how to fix this?

Thanks,

Sean McGilvray

Comments and changes to this ticket

  • Shahrooz Bhopti

    Shahrooz Bhopti February 23rd, 2010 @ 01:10 PM

    Search doesn't pull from the email on phone fields in my testing. All encompassing search fields would be welcome :)

  • Roman Smirnov

    Roman Smirnov March 10th, 2010 @ 04:12 AM

    You should find in models simple_column_search call and add :email, :phone to args, for example:

    app/models/account.rb:56

    simple_column_search :name, :email, :phone, :match => :middle, :escape => lambda { |query| query.gsub(/[^\w\s\-\.']/, "").strip }
    

    instead of

    simple_column_search :name, :match => :middle, :escape => lambda { |query| query.gsub(/[^\w\s\-\.']/, "").strip }
    
  • Wai-Sun Chia

    Wai-Sun Chia March 17th, 2010 @ 05:56 AM

    Wow! Thanks a million, this works fantastically!!
    I've been looking for this multi-fields search capability for quite awhile!!

  • Mike Dvorkin

    Mike Dvorkin April 25th, 2010 @ 06:07 PM

    • Milestone changed from 0.9.10 "Alekhine" to 0.9.11 "Euwe"
    • State changed from “new” to “open”

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Ruby on Rails CRM platform for Web 2.0 and beyond

Tags

Pages